Devoir de contrôle N°2

Voir le sujet précédent Voir le sujet suivant Aller en bas

Devoir de contrôle N°2

Message par haiethem le Sam 26 Jan - 8:30

Devoir de contrôle N°2 (Epreuve théorique)

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Sam 26 Jan - 8:36

Exercice1

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

0)DEF FN C(n,p:entier):entier

1)Résultat = [] SI (n=p)ou(p=0) alors C ← 1

sinon C ← FN(n-1,p-1)+FN C(n,p-1)

FINSI

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Sam 26 Jan - 8:40

Exercice2

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*


Analyse :

3)Résultat = [ ] SI s mod 7 = 0 alors écrire (n,"est divisible par 7")

sinon écrire(n,"n'est pas divisible par 7")

FINSI

1)n = PROC saisir(n)

2)s ← FN calcul(n)


Dernière édition par haiethem le Sam 26 Jan - 8:44, édité 1 fois

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Sam 26 Jan - 8:42

Analyse de la procedure saisir:

0)DEF PROC saisir(var n:chaine de caractères)

Résultat = n

1)n = [ ] repéter

n=donnée ("Donner un nombre d'au moins 15 chiffres")

jusqu'à FN verif(n)

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Sam 26 Jan - 8:48

Analyse de la fonction verif:

0)DEF FN verif (n:chaine de caractères):booléen

2)Résultat = verif ← (i>long(n))et(long(n)>=15)

1)i=[i ← 1] tantque (i<=long(n))et(ch[i]dans["0".."9"])faire

i ← i+1

fin tantque

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Sam 26 Jan - 9:17

Analyse de la fonction calcul:

0)DEF FN calcul(n:chaine de caractères):entier


2)Résultat = calcul ← s

1) s = [s←0,c←-1,j←1,i←long(n) ]répéter

si j = 3 alors insère("*",n,i)

finsi
i ← i - 1


j ← j + 1

si j = 4 alors j ← 1

finsi

jusqu'à i = 1

répéter

ch ← sous_chaine(n,1,pos("*",n)-1)

valeur (ch,d,e)

efface(n,1,pos("*",n)

s ← s + c * d

c ← - c

jusqu'à pos("*",n)=0

valeur(n,d,e)

s ← s + c * d

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Sam 26 Jan - 9:39

Exercice3.

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

Analyse :

2)Résultat = PROC affiche(n)

1)n = PROC saisir(n)

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Sam 26 Jan - 9:43

Analyse de la procedure saisir:

0)DEF PROC saisir(var n:entier)

Résultat = n

n = [ ] répéter

n ← aléa (100)

jusqu'à n>0


***********************************

Remarque : On peut faire n ← 1+aléa(100)

Le nombre 100 n'est qu'un choix


Dernière édition par haiethem le Sam 26 Jan - 9:53, édité 1 fois

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Sam 26 Jan - 9:52

Analyse de la procedure affiche:

0)DEF PROC affiche (n:entier)

2)Résultat = écrire("durée = ",d," Altitude max = ",max," Durée de vol en altitude = ",dva)

1)(d,max,dva)=[d←1,max←n,p←n,dva←1 ] Répéter

écrire(n)

si n mod 2 = 0 alors n ← n div 2

sinon n ← n * 3 + 1

finsi

d ← d + 1

si n > max alors max ← n

finsi

si n > p alors dva ← dva + 1

finsi

jusqu'à n = 1

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par Mondher le Dim 27 Jan - 0:02

Salem
l'exercice 2 nous a demandé d'entrer un nombre n alors faut quil soit un entier long de taille min 15 chiffres nn ? theoriquement cest possible ? spk jvois ke le teste de l'abscence de tout caractere nappartient pas à l'intervalle ["0".."9"] n'a pas d'importance

Mondher

Messages : 57
Points : 9146
Réputation : 0
Date d'inscription : 24/09/2012
Age : 22
Localisation : Tunisie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par Mondher le Dim 27 Jan - 0:11

-2147483648<=entier long<=2147483647 ????

Mondher

Messages : 57
Points : 9146
Réputation : 0
Date d'inscription : 24/09/2012
Age : 22
Localisation : Tunisie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Dim 27 Jan - 11:38

Comment un entier long peut avoir 15 chiffres ?

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par Mondher le Dim 27 Jan - 12:00

ui il pe pas :/
alors cee fo de declarer n comme etant un entier ? Sad

Mondher

Messages : 57
Points : 9146
Réputation : 0
Date d'inscription : 24/09/2012
Age : 22
Localisation : Tunisie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Dim 27 Jan - 22:57

Bien sûr !!!!!!!!!!!!

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par Mondher le Dim 27 Jan - 23:22

meme """"theoriquement"""" Very Happy ?

Mondher

Messages : 57
Points : 9146
Réputation : 0
Date d'inscription : 24/09/2012
Age : 22
Localisation : Tunisie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Lun 28 Jan - 22:30

T'inquiète pas !!??

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14615
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum