Devoir de contrôle N°2

Voir le sujet précédent Voir le sujet suivant Aller en bas

Devoir de contrôle N°2

Message par haiethem le Lun 11 Fév - 9:57

Cryptage

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=

Analyse:

Résultat = écrire(chcryp)

chcryp=[]pour i de 1 à long ch faire

si ch[i] dans ["A".."Z"] alors

chcrypt[i]←chr(ord(ch[i])+n)

si ord(chcrypt[i])>ord("Z") alors chcrypt[i]←chr(ord(chcrypt[i])-26)

finsi

sinon si ch[i] dans ["a".."z"] alors

chcrypt[i]←chr(ord(ch[i])+n)

si ord(chcrypt[i])>ord("z") alors chcrypt[i]←chr(ord(chcrypt[i])-26)

finsi

sinon chcryp[i]←ch[i]

finsi

finpour

ch=donnée("donner la chaine à crypter")

n=[]repeter

n=donnée ("donner n")

jusqu'à n dans [2..25]

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk

haiethem

Messages : 410
Points : 13703
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°2

Message par haiethem le Lun 11 Fév - 21:29

I.M.E.I.

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=

Analyse:

Résultat = écrire(msg)

msg=[]si s mod 10 = 0 alors msg←"IMEI valide"

sinon msg←"IMEI non valide"

finsi

s=[]pour i de 1 à long(n) faire

valeur(n[i],d,e)

si i mod 2 = 0 alors d ← d*2

finsi

si d>9 alors d ← d mod 10 + d div 10

finsi

s ← s + d

finpour

n=[] répéter

n=donnée("donner un entier de 15 chiffres")

jusqu'à long(n) = 15

objettype/naturerôle
msgchaine de caractèresmessage
sentiersomme
nchaine de caractèresnombre IMEI
ientiercompteur
dentiervaleur
eentiererreur

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk

haiethem

Messages : 410
Points : 13703
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum