Exercice cube d'un nombre

Poster un nouveau sujet   Répondre au sujet

Voir le sujet précédent Voir le sujet suivant Aller en bas

Exercice cube d'un nombre

Message par haiethem le Dim 21 Avr - 13:06

Exercice :
=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=
DEF PROC affiche (n:entier)
Résultat =
[d←1] répéter
[ j←d,s←0]
répéter
s←s+j
j←j+2
jusqu'à s>=n*n*n
si s=n*n*n alors
i←d
écrire(n,"^3 =",s," = ")
répéter
si i<>d alors écrire("+")
finsi
écrire(i)
i←i+2
jusqu'à i=j
écrire_nl
finsi
d←d+2
jusqu'à d>=n*n*n div 2 + 1
=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=
program cube;
uses wincrt;
var d,s,j,n,i:integer;
procedure affiche;
begin
d:=1;
repeat
j:=d;
s:=0;
repeat
s:=s+j;
j:=j+2;
until s>= n*n*n;
if s = n*n*n then
begin
i:=d;
write(n,'^3 = ',s,' = ');
repeat
if i <> d then write(' + ');
write (i:5);
i:=i+2;
until i=j;
writeln;
end;
d:=d+2;
until d>= (n*n*n)div 2 +1;
end;
begin
readln(n);
affiche;
end.

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 418
Points : 14190
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Exercice cube d'un nombre

Message par Mondher le Dim 21 Avr - 23:16

DEF PROC affiche (n:entier)
Résultat =
[d←1; verif<--faux] répéter
[ j←d,s←0]
répéter
s←s+j
j←j+2
jusqu'à s>=n*n*n
si s=n*n*n alors
i←d
verif<--vrai
écrire(n,"^3 =",s," = ")
répéter
si i<>d alors écrire("+")
finsi
écrire(i)
i←i+2
jusqu'à i=j
écrire_nl
finsi
d←d+2
jusqu'à (d>=n*n*n div 2 + 1) ou (verif)

Mondher

Messages : 57
Points : 8726
Réputation : 0
Date d'inscription : 24/09/2012
Age : 22
Localisation : Tunisie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous pouvez répondre aux sujets dans ce forum