Devoir de synthèse N°2

Voir le sujet précédent Voir le sujet suivant Aller en bas

Devoir de synthèse N°2

Message par haiethem le Sam 10 Mar - 12:10

Exercice 1 :
a- recurrence d'ordre 2
b- 11
c- suite de fibonacci de coefficient x
=======================
Exercice 2 :
program ex2;
uses wincrt;
var d,s,j,n,i:integer;
procedure affiche;
begin
d:=1;
repeat
j:=d;
s:=0;
repeat
s:=s+j;
j:=j+2;
until s>= n*n*n;
if s = n*n*n then
begin
i:=d;
write(n,'^3 = ',s,' = ');
repeat
if i <> d then write(' + ');
write (i:5);
i:=i+2;
until i=j;
writeln;
end;
d:=d+2;
until d>= (n*n*n)div 2 +1;
end;
begin
readln(n);
affiche;
end.
=======================
Exercice 3 :
program ds2ex3;
uses wincrt;
type mat = array[1..10,1..10]of real;
var
m:mat;
n,c,l,i:integer;

procedure afficher(p:real);
begin
writeln('Le PPCM des PPCMs est : ',p:5:0);
end;
procedure saisir;
begin
repeat
readln(n) until n in [3..10];
end;

function pgcd(a,b:real):real;
begin
if a=b then pgcd:=a
else if a>b then pgcd:=pgcd(a-b,b)
else pgcd:=pgcd(a,b-a);
end;
function ppcm(a,b:real):real;
begin
ppcm:=a*b/pgcd(a,b);
end;
procedure remplir;
begin
for c:=1 to n do
repeat readln(m[1,c]) until m[1,c]>0;
for l:=2 to n do
for c:=1 to n-l+1 do
m[l,c]:=ppcm(m[l-1,c],m[l-1,c+1]);
end;

begin
saisir;
remplir;
afficher(m[n,1]);
end.
=======================
Exercice 4 :
resultat = proc affiche(decimal,compacte)
decimal = proc remplir(decimal)
compacte = proc enreg (m,conversion,compacte)
conversion = (proc convrtir (decimal,conversion)
=+=+=+=+=+=+=+=
def proc affiche(var d:f_ent;var c:texte)
resultat =
[ouvrir(d)] tantque non fin_fichier(d)faire
lire(d,e)
écrire(e)
fin tantque
fermer(d)
[ouvrir(c)] tantque non fin_fichier(d)faire
lire(d,ch)
écrire(ch)
fin tantque
fermer(c)
=+=+=+=+=+=+=+=
def proc remplir(var d:f_ent)
résultat = d
d=[e=donnée , recréer(d) ] tantque e >0 faire
écrire (d,e)
e=donnée
fin tantque
=+=+=+=+=+=+=+=
def proc convertir(var d:f_ent; var c:f_enr)
résultat = c
c = [ouvrir(d) , recréer (c)] tantque non fin_fichier( d) faire
lire(d,n)
e.decimal ← n
e.bin ← FN conv(n)
écrire ( c,e )
fin tantque
fermer(c) , fermer (d)

DEF FN conv (n:entier):cahine de caractères
résultat = conv ← ch
ch =[ch ← ""] repeter
r ← n mod 2
convch(r,rch)
ch ← rch +ch
n ← n div 2
jusqu'à n = 0
=+=+=+=+=+=+=+=
def proc enreg (var m:mat ; var c:f_enr; var comp : texte)
résultat = comp
comp=[ouvrir (c), recréer (comp)] tantque non fin_fichier (c) faire
lire(c,e)
proc remp(m,e.bin)
écrire_nl(comp,FN former(m))
fin tantque
fermer(c) , fermer(comp)
=+=+=+=+=+=+=+=
def proc remp (var m:mat; ch :chaine de caractères)
résultat = m
m=[i←1 , b← ch[i], nb←1, co←1] repeter
a←ch[i]
si a ≠ b alors
b←ch[i]
m[1,co] ← nb
nb←1
co←co+1
finsi
i←i+1
nb←nb+1
jusqu'à i > long(ch)
=+=+=+=+=+=+=+=
def fn former (m:mat):chaine de caractères
résultat = former ←ch
ch=[ch←"" , co←1] tantque m[2,co] ≠ 0 faire
convch(m[2,co],rch)
ch←ch+rch
fin tantque

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14470
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de synthèse N°2

Message par haiethem le Mar 20 Mar - 1:02

....

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 419
Points : 14470
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum