Sujet Algo & Prog. Juin 2012

Voir le sujet précédent Voir le sujet suivant Aller en bas

Sujet Algo & Prog. Juin 2012

Message par haiethem le Jeu 7 Juin - 11:34

Exercice 1:

-------------------------------

Pour Cj de Mardi à Samedi faire

Va[Cj].Jrs ← Cj

Fin pour

V

-------------------------------

Ecrire (Fa,Avend.CodeArt)

F

Cette instruction est fausse car Fa est un fichier de Enreg alors que Avend.CodeArt est une chaine de 10 caractères

-------------------------------

Lire(Avend.Jrs)

F

Cette instruction est fausse car Avend.Jrs est de type jours et le type scalaire ne peut être ni lu ni écrit.

-------------------------------

Test ← Fin_fichier(Ft) = Faux

V

-------------------------------

Ecrire(Fe,R)

F

Cette instruction est fausse car Fe est un fichier d'entier alors que R est un réel.

-------------------------------

Test ← Va[lundi]>Va[Jeudi]

F

Cette instruction est fausse car Va[lundi] et Va[Jeudi] sont deux enregistrements et la comparaison n'est pas valide entre deux enregistrements

-------------------------------

=================================


Dernière édition par haiethem le Sam 9 Juin - 11:23, édité 1 fois

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk

haiethem

Messages : 410
Points : 13688
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Exercice 2:

Message par haiethem le Jeu 7 Juin - 12:17

Exercice 2:

-------------------------------

a) Tableau des objets locaux :



b) Pour N = 4 , cette procedure remplit les quatres premières lignes du triangle de Pascal

c) Cette procedure remplit le triangle de Pascal.


Dernière édition par haiethem le Sam 9 Juin - 11:41, édité 3 fois

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk

haiethem

Messages : 410
Points : 13688
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Exercice 3 :

Message par haiethem le Jeu 7 Juin - 12:29

Exercice 3 :

--------------------------

0) debut

1) PROC saisir(x)

2) eps = 0.0001

3) x0 ← FN calcul (x,eps)

4) PROC affiche (x0)

--------------------------

0) DEF PROC saisir( var x: réel)

1) répeter

x = donnée

jusqu'à (x<=1) et (x>=-1)

2) fin

Remarque : il n'est pas possible d'utiliser x dans [-1..1] car x est un réel

--------------------------

0) DEF FN calcul (x,eps:réel):réel

1)s←0

2)s1 ← 1

3) i ←2

4) c ← -1

5) tantque abs(s-s1) > eps faire

s← s1

s1 ← s1 + c * FN puis(x,i)/ FN fact(i)

i←2+i

c← - c

fintantque

6) calcul ← s1

7) FIN

--------------------------

0) DEF PROC affiche (x0:réel)

1)écrire("la solution est : ",x0)

2) FIN

--------------------------

0) DEF FN puis (a:réel;b:entier):réel

1) p ← 1

2) pour i de 1 à b faire

p ← p * a

finpour

3) puis ← p

4) Fin

--------------------------

0) DEF FN fact (n:entier):entier

1) p ← 1

2) pour i de 1 à n faire

p ← p * i

finpour

3) fact ← p

4) Fin

--------------------------


Dernière édition par haiethem le Jeu 14 Juin - 10:38, édité 3 fois

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk

haiethem

Messages : 410
Points : 13688
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Problème :

Message par haiethem le Jeu 7 Juin - 16:05

Problème :

-------------------------------

Résultat = PROC Affiche(br,cod)

br = associer (br,"c:\braille.txt")

cod = associer (cod, "c:\codes_brailles.dat")

-------------------------------

DEF PROC affiche( var br : texte; var cod : f_enr)

Résultat =

[ouvrir(br)] tantque non fin_fichier(br) faire

lire_nl(br,ch)

repeter

ch1 ← sous_chaine(ch,1,6)

efface(ch,1,6)

[ouvrir(cod)] repeter

lire(cod,e)

jusqu'à e.codage = ch1

écrire(e.lettre)

jusqu'à (long(ch)=0)

écrire (" ")

fintantque

fermer(br), fermer(cod)

-------------------------------

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk

haiethem

Messages : 410
Points : 13688
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Sujet Algo & Prog. Juin 2012

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum