Application "societe"

Voir le sujet précédent Voir le sujet suivant Aller en bas

Application "societe"

Message par haiethem le Sam 29 Sep - 11:22

Résultat = 3) PROC affiche (t,n)

2) t = PROC remplir(t,n)

1) n = PROC saisir (n)


TYPE
emp = enregistrement

n_p:chaine de caractères

tel:chaine[8]

grade : caractère

ass : caractère

fin emp

tab = tableau de 50 emp


objet

type/nature

rôle
affiche

t

n

saisir

remplir
procedure

tab

entier

procedure

procedure
affichage

tableau

taille

saisir n

remplir t

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

Analyse des modules:

0) DEF PROC saisir (var n:entier)

3) résultat = n

1) n=[ ] répeter n=donnée("donner n ")

jusqu'à n dans [1..50]

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

0) DEF PROC remplir (var t:tab ; n:entier)

2) résultat = t

1) t=[ ] pour i de 1 à n faire

avec t[i] faire

n_p=donnée

répeter tel = donnée

jusqu'à FN verif(tel)

répeter grade = donnée

jusqu'à grade dans ['A,'B,'C]

répeter ass = donnée

jusqu'à ass dans ['O','N']

fin avec

fin pour

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

0) DEF FN verif (ch:chaine de caractères):booléen

2) résultat = verif ← (i > long(ch))

1) i=[i ← 0] répeter

i ← i+1

jusqu'à (i >long(ch)) ou (non (ch[i] dans ['0'..'9']))

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

0) DEF PROC affiche (t:tab ; n:entier)

3) résultat = affichage

2) affichage = [ ] pour i de 1 à n faire

avec t[i] faire

si (ass = 'O') et (grade = g ) alors

écrire (n_p,tel,grade,"est assuré")

finsi

1) g= [ ] répeter

g = donnée ("donner une grade")

jusqu'à d dans ['A'..'C']

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 425
Points : 14917
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum