Devoir de contrôle N°1

Voir le sujet précédent Voir le sujet suivant Aller en bas

Devoir de contrôle N°1

Message par haiethem le Ven 19 Oct - 23:38

Exercice 1 :

1- Vrai

2- Vrai

3- Faux

4- Faux

5- Faux

6- Faux

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

Exercice 2:

DEF PROC remplir(var f:f_voiture ; var n: entier)

résultat = f

f=[ associer(f,"c:\parc\voitures.don" ,recréer(f) ] pour i de 1 à n faire

v.mar = donnée ("donner la marque")

v.d_circ= donnée ("donner la dat de circulation")

v.p = donnée ("donner la puissance")

répeter

v.c = donnée ("donner le carburant")

jusqu'à v.c dans["D","E"]

écrire (f,v)

finpour

fermer(f)

n= [ ] répeter

n=donnée ("donner n")

jusqu'à n>0

-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-

DEF PROC remplirDE (var f,d,e : f_voiture)

résultat = (d,e)

(d,e) = [ouvrir(f) , recréer(d) , recréer(e)] tantque non fin_fichier(f) faire

lire(f,v)

si v.c = "D" alors

écrire (d,v)

sinon

écrire (e,v)

finsi

fin tantque

fermer(f) , fermer(d) , fermer(e)

-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-

DEF PROC affiche (var f : f_voiture)

résultat = affichage

[ ] tantque non fin_fichier(f) faire

lire (f,v)

écrire (v.mar , v.c)

fin tantque

fermer (f)

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

Exercice 3:

DEF PROC result (var f : f_etu ; var g : f_res)

résultat = g

g = [recréer (g) , ouvrir (f)] tantque non fin_fichier (f) faire

lire (f,e)

r.nom ← e.nom

r.pre ← e.pre

r.cin ← e.cin

r.moy ← (e.moy1+e.moy2)/2

écrire (g,r)

fin tantque

fermer (f) , fermer (g)

-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-

DEF FN pourcent (var g : f_res) : réel

résultat = pourcent ← p*100/n

(n,p) = [ouvrir (g) , n ← 0 , p ← 0] tantque non fin_fichier (g) faire

lire (g,r)

n ← n + 1

si r.moy >= 10

alors p ← p + 1

finsi

fin tantque

fermer (g)

-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-

DEF PROC affiche (var f : f_etu)

résultat =

[ouvrir (f)] tantque non fin_fichier (f) faire

lire(f,e)

si e.moy2 >= 10

alors écrire (e.nom , e.pre)

finsi

fin tantque

fermer (f)

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 425
Points : 14917
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum