Devoir de contrôle N°1 (4SC1)

Voir le sujet précédent Voir le sujet suivant Aller en bas

Devoir de contrôle N°1 (4SC1)

Message par haiethem le Jeu 8 Nov - 8:29

Sujet 1:

Résultat = écrire("Le résultat est :",r)

r=[ ] si op = "+" alors

s ← a + b

sinon si op = "-" alors

s ← a - b

sinon si op = "*" alors

s ← a * b

sinon si op = "/" alors

s ← a / b

sinon écrire ("erreur")

finsi

( a,b ) = donnée ("donner a et b")

objettype/naturerôle
rréelresultat
aréela
bréelb
=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

Sujet 2 :

Résultat = écrire (nat)

nat= [ ] si c dans ["0".."9"] alors

nat ← "chiffre"

sinoin si (majus(c) dans ["A".."Z"]) alors

nat ← "alphabet"

sinon si c dans ["+","-","/","*"] alors

nat ← "opérateur"

sinon nat ← "caratères spéciaux"

finsi

c = donnée ("taper un caractère")

objettype/naturerôle
ccaractèretouche tapée
natchaine de caractèresnature du caractère

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 426
Points : 15098
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Re: Devoir de contrôle N°1 (4SC1)

Message par haiethem le Sam 10 Nov - 9:49

Bonjour chèrs élèves :

Les notes sont entre 12 et 20

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk
avatar
haiethem

Messages : 426
Points : 15098
Réputation : 3
Date d'inscription : 08/11/2010
Age : 41

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum