Devoir de synthèse N°1

Voir le sujet précédent Voir le sujet suivant Aller en bas

Devoir de synthèse N°1

Message par haiethem le Jeu 13 Déc - 11:18

Exercice 1 :
X=1
Y=7
Ch1="PASCAL"
Ch2="ALGORITHMIQUE"
=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
Exercice 2 :
InstructionValide/ Non Valide Justification
test:=ord(Math)Valide
A:="Math"; Non valide A est de type scalaire énuméré
Write(S);Non valide Write n'est pas possible pour le type scalaire énuméré
M:=ord(Automne); Valide
=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
Exercice 3 :
Résultat = écrire (M)
M← N1 div 10 *1000 + N2 div 10 *100 + N2 mod 10 *10 + N1 mod 10
N1,N2 = donnée ("donner N1 et N2")
Objet Type/Nature Rôle
M entier
N1 entier
N2 Entier
=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
Exercice 4 :
Résultat = écrire (h,":",m,":",s)
h,m,s = donnée
[s←s+1] SI s = 60 alors
s ← 0
m ← m+1
SI m = 60 alors
m ← 0
h ← h+1
SI h = 24 alors
h ← 0
Finsi
Finsi
Finsi
ObjetType/Nature Rôle
h entier heures
mentier minutes
sentier secondes

_________________
=================================
Haiethem Elguediri
Lycée Secondaire Mareth
+21652084191
+21652906038
+21631139805
+21675321050
haiethem@gmail.com
www.haiethem.tk

haiethem

Messages : 410
Points : 13703
Réputation : 3
Date d'inscription : 08/11/2010
Age : 40

Voir le profil de l'utilisateur http://www.haiethem.tk

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum